summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTobias Klauser <tklauser@access.unizh.ch>2007-08-04 18:59:17 +0200
committerMichael Meskes <meskes@debian.org>2008-08-27 13:45:17 +0200
commit34df00ecc0ea7198df4d64f17c17b0495aaa06b3 (patch)
tree965c4670b11e8467e24cb548d084538049f3baf4 /debian
parentf06a98f0b468601fc1ab929b06a7962cca8614ea (diff)
Imported Debian patch 0.1-1
Diffstat (limited to 'debian')
-rw-r--r--debian/acpitail.139
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/copyright27
-rw-r--r--debian/docs1
-rwxr-xr-xdebian/rules49
7 files changed, 139 insertions, 0 deletions
diff --git a/debian/acpitail.1 b/debian/acpitail.1
new file mode 100644
index 0000000..a030186
--- /dev/null
+++ b/debian/acpitail.1
@@ -0,0 +1,39 @@
+.TH acpitail 1 "2007-08-04" "" ""
+.SH NAME
+acpitail \- Show ACPI information in a tail-like style
+.SH SYNOPSIS
+.B acpitail
+[OPTION]...
+.SH DESCRIPTION
+.B acpitail
+shows ACPI status information about battery, fan and temperature in a tail-like
+manner. As soon as a value changes, the new value gets appended to the current
+output.
+.SH OPTIONS
+.TP
+.B \-A \fIx\fR
+set update interval for AC state information to \fIx\fR seconds (default: 300)
+.TP
+.B \-B \fIx\fR
+set update interval for battery information to \fIx\fR seconds (default: 15)
+.TP
+.B \-F \fIx\fR
+set update interval for fan information to \fIx\fR seconds (default: 5)
+.TP
+.B \-Z \fIx\fR
+set update interval for zone information to \fIx\fR seconds (default: 5)
+.TP
+.B \-h
+show help
+.TP
+.B \-V
+show version information
+.SH AUTHORS
+.PP
+acpitail is developed by Folkert van Heusden <folkert@vanheusden.com>.
+This manual page was written by Tobias Klauser <tklauser@distanz.ch> for the Debian
+system (but may be used by others).
+.SH SEE ALSO
+.PP
+.BR libacpi(3),
+.BR yacpi(1)
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..a80e302
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+acpitail (0.1-1) unstable; urgency=low
+
+ * Initial release. (Closes: #430022)
+ * Added manpage
+
+ -- Tobias Klauser <tklauser@access.unizh.ch> Sat, 04 Aug 2007 18:59:17 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..14c5c30
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: acpitail
+Section: utils
+Priority: optional
+Maintainer: Tobias Klauser <tklauser@access.unizh.ch>
+Build-Depends: debhelper (>= 5), libacpi-dev
+Standards-Version: 3.7.2
+
+Package: acpitail
+Architecture: i386 amd64 ia64
+Depends: ${shlibs:Depends}
+Description: Show ACPI information in a tail-like style
+ acpitail shows ACPI status information about battery, fan and
+ temperature in a tail-like way. As soon as a value changes, the new
+ value gets appended to the current output.
+ .
+ Homepage: <http://www.vanheusden.com/acpitail/>
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..1389ea1
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,27 @@
+This package was debianized by Tobias Klauser <tklauser@access.unizh.ch> on
+Fri, 22 Jun 2007 18:59:39 +0200.
+
+It was downloaded from <http://www.vanheusden.com/acpitail/>.
+
+Upstream Author: Folkert van Heusden <folkert@vanheusden.com>
+
+License:
+
+ Copyright (C) 2007 Folkert van Heusden <folkert@vanheusden.com>
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in /usr/share/common-licenses/GPL file.
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..b2b2a78
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+readme.txt
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ea5a1f2
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,49 @@
+#!/usr/bin/make -f
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+
+ $(MAKE)
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ $(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs usr/bin
+
+ install -m755 -p acpitail $(CURDIR)/debian/acpitail/usr/bin/
+
+binary-indep: build install
+# We have nothing to do by default.
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_install
+ dh_installman debian/acpitail.1
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install