summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules49
1 files changed, 5 insertions, 44 deletions
diff --git a/debian/rules b/debian/rules
index 090b681..e59be58 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,49 +1,10 @@
#!/usr/bin/make -f
-build: build-stamp
-build-stamp:
- dh_testdir
+%:
+ dh ${@}
- $(MAKE)
+override_dh_auto_install:
+ install -m755 -D -p acpitail $(CURDIR)/debian/acpitail/usr/bin/acpitail
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- $(MAKE) clean
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs usr/bin
-
- install -m755 -p acpitail $(CURDIR)/debian/acpitail/usr/bin/
-
-binary-indep: build install
-# We have nothing to do by default.
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_install
+override_dh_installman:
dh_installman debian/acpitail.1
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install