summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in99
1 files changed, 99 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..76bf2dc
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,99 @@
+dnl This file is part of the KDE libraries/packages
+dnl Copyright (C) 2001 Stephan Kulow (coolo@kde.org)
+
+dnl This file is free software; you can redistribute it and/or
+dnl modify it under the terms of the GNU Library General Public
+dnl License as published by the Free Software Foundation; either
+dnl version 2 of the License, or (at your option) any later version.
+
+dnl This library is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+dnl Library General Public License for more details.
+
+dnl You should have received a copy of the GNU Library General Public License
+dnl along with this library; see the file COPYING.LIB. If not, write to
+dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+dnl Boston, MA 02111-1307, USA.
+
+# Original Author was Kalle@kde.org
+# I lifted it in some mater. (Stephan Kulow)
+# I used much code from Janos Farkas
+
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(acinclude.m4) dnl a source file from your sub dir
+
+dnl This is so we can use kde-common
+AC_CONFIG_AUX_DIR(admin)
+
+dnl This ksh/zsh feature conflicts with `cd blah ; pwd`
+unset CDPATH
+
+dnl Checking host/target/build systems, for make, install etc.
+AC_CANONICAL_SYSTEM
+dnl Perform program name transformation
+AC_ARG_PROGRAM
+
+dnl Automake doc recommends to do this only here. (Janos)
+AM_INIT_AUTOMAKE(c_cpp_reference, 2.0.2) dnl searches for some needed programs
+
+KDE_SET_PREFIX
+
+dnl generate the config header
+AM_CONFIG_HEADER(config.h) dnl at the distribution this done
+
+dnl Checks for programs.
+AC_CHECK_COMPILERS
+AC_ENABLE_SHARED(yes)
+AC_ENABLE_STATIC(no)
+KDE_PROG_LIBTOOL
+
+dnl for NLS support. Call them in this order!
+dnl WITH_NLS is for the po files
+AM_KDE_WITH_NLS
+
+AC_PATH_KDE
+#MIN_CONFIG
+
+dnl PACKAGE set before
+
+KDE_CREATE_SUBDIRSLIST
+AC_OUTPUT( \
+./Makefile \
+reference/Makefile \
+reference/C/Makefile \
+reference/C/CONCEPT/Makefile \
+reference/C/CONTRIB/Makefile \
+reference/C/CONTRIB/OR_PRACTICAL_C/Makefile \
+reference/C/CONTRIB/OR_USING_C/Makefile \
+reference/C/CONTRIB/SAWTELL/Makefile \
+reference/C/CONTRIB/SNIP/Makefile \
+reference/C/CONTRIB/YABL/Makefile \
+reference/C/EXAMPLES/Makefile \
+reference/C/FUNCTIONS/Makefile \
+reference/C/GDB/Makefile \
+reference/C/LIBRARIES/Makefile \
+reference/C/MAN/Makefile \
+reference/C/MISC/Makefile \
+reference/C/MISC/CLASSES/Makefile \
+reference/C/PROBLEMS/Makefile \
+reference/C/SYNTAX/Makefile \
+reference/C/TECHNIC/Makefile \
+reference/C/X_EXAMPLES/Makefile \
+reference/C/backup/Makefile \
+reference/CPLUSPLUS/Makefile \
+reference/CPLUSPLUS/CONCEPT/Makefile \
+reference/CPLUSPLUS/CONTRIB/Makefile \
+reference/CPLUSPLUS/CONTRIB/GNU_STDLIB/Makefile \
+reference/CPLUSPLUS/EXAMPLES/Makefile \
+reference/CPLUSPLUS/FUNCTIONS/Makefile \
+reference/CPLUSPLUS/GDB/Makefile \
+reference/CPLUSPLUS/LIBRARIES/Makefile \
+reference/CPLUSPLUS/MISC/Makefile \
+reference/CPLUSPLUS/PROBLEMS/Makefile \
+reference/CPLUSPLUS/SYNTAX/Makefile \
+reference/CPLUSPLUS/TECHNIC/Makefile \
+reference/CPLUSPLUS/X_EXAMPLES/Makefile \
+reference/GRAPHICS/Makefile \
+)