summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klauser <tklauser@distanz.ch>2008-05-18 19:44:14 +0200
committerTobias Klauser <tklauser@xenon.tklauser.home>2008-05-18 19:44:14 +0200
commitd547fc2a1be23e18c34eb189150ef55db8bc5c56 (patch)
tree63b85d572e34e6ba1f7c18c4f57f889236e9297f
parentb98e8def5fe980cd6fccb24ecaf6daaa28663234 (diff)
Fix Bashisms in contrib/ocs (Closes: #480591)15.6-6
-rwxr-xr-xconfig.guess32
-rwxr-xr-xconfig.sub44
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/03-fix-ocs-bashisms.dpatch67
5 files changed, 130 insertions, 19 deletions
diff --git a/config.guess b/config.guess
index 278f9e9..f32079a 100755
--- a/config.guess
+++ b/config.guess
@@ -1,10 +1,10 @@
#! /bin/sh
# Attempt to guess a canonical system name.
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-# 2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
-# Inc.
+# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
+# Free Software Foundation, Inc.
-timestamp='2007-07-22'
+timestamp='2008-01-23'
# This file is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
@@ -56,8 +56,8 @@ version="\
GNU config.guess ($timestamp)
Originally written by Per Bothner.
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
-Free Software Foundation, Inc.
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
+2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
@@ -532,7 +532,7 @@ EOF
echo rs6000-ibm-aix3.2
fi
exit ;;
- *:AIX:*:[45])
+ *:AIX:*:[456])
IBM_CPU_ID=`/usr/sbin/lsdev -C -c processor -S available | sed 1q | awk '{ print $1 }'`
if /usr/sbin/lsattr -El ${IBM_CPU_ID} | grep ' POWER' >/dev/null 2>&1; then
IBM_ARCH=rs6000
@@ -799,6 +799,9 @@ EOF
EM64T | authenticamd)
echo x86_64-unknown-interix${UNAME_RELEASE}
exit ;;
+ IA64)
+ echo ia64-unknown-interix${UNAME_RELEASE}
+ exit ;;
esac ;;
[345]86:Windows_95:* | [345]86:Windows_98:* | [345]86:Windows_NT:*)
echo i${UNAME_MACHINE}-pc-mks
@@ -833,7 +836,14 @@ EOF
echo ${UNAME_MACHINE}-pc-minix
exit ;;
arm*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ eval $set_cc_for_build
+ if echo __ARM_EABI__ | $CC_FOR_BUILD -E - 2>/dev/null \
+ | grep -q __ARM_EABI__
+ then
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
+ else
+ echo ${UNAME_MACHINE}-unknown-linux-gnueabi
+ fi
exit ;;
avr32*:Linux:*:*)
echo ${UNAME_MACHINE}-unknown-linux-gnu
@@ -954,8 +964,8 @@ EOF
x86_64:Linux:*:*)
echo x86_64-unknown-linux-gnu
exit ;;
- xtensa:Linux:*:*)
- echo xtensa-unknown-linux-gnu
+ xtensa*:Linux:*:*)
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
exit ;;
i*86:Linux:*:*)
# The BFD linker knows what the default object file format is, so
@@ -1474,9 +1484,9 @@ This script, last modified $timestamp, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from
- http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
+ http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD
and
- http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub
+ http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub;hb=HEAD
If the version you run ($0) is already up to date, please
send the following data and any information you think might be
diff --git a/config.sub b/config.sub
index 1761d8b..6759825 100755
--- a/config.sub
+++ b/config.sub
@@ -1,10 +1,10 @@
#! /bin/sh
# Configuration validation subroutine script.
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-# 2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
-# Inc.
+# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
+# Free Software Foundation, Inc.
-timestamp='2007-06-28'
+timestamp='2008-01-16'
# This file is (in principle) common to ALL GNU software.
# The presence of a machine in this file suggests that SOME GNU software
@@ -72,8 +72,8 @@ Report bugs and patches to <config-patches@gnu.org>."
version="\
GNU config.sub ($timestamp)
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
-Free Software Foundation, Inc.
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
+2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
@@ -369,10 +369,14 @@ case $basic_machine in
| v850-* | v850e-* | vax-* \
| we32k-* \
| x86-* | x86_64-* | xc16x-* | xps100-* | xscale-* | xscalee[bl]-* \
- | xstormy16-* | xtensa-* \
+ | xstormy16-* | xtensa*-* \
| ymp-* \
| z8k-*)
;;
+ # Recognize the basic CPU types without company name, with glob match.
+ xtensa*)
+ basic_machine=$basic_machine-unknown
+ ;;
# Recognize the various machine names and aliases which stand
# for a CPU type and a company and sometimes even an OS.
386bsd)
@@ -443,6 +447,14 @@ case $basic_machine in
basic_machine=ns32k-sequent
os=-dynix
;;
+ blackfin)
+ basic_machine=bfin-unknown
+ os=-linux
+ ;;
+ blackfin-*)
+ basic_machine=bfin-`echo $basic_machine | sed 's/^[^-]*-//'`
+ os=-linux
+ ;;
c90)
basic_machine=c90-cray
os=-unicos
@@ -668,6 +680,14 @@ case $basic_machine in
basic_machine=m68k-isi
os=-sysv
;;
+ m68knommu)
+ basic_machine=m68k-unknown
+ os=-linux
+ ;;
+ m68knommu-*)
+ basic_machine=m68k-`echo $basic_machine | sed 's/^[^-]*-//'`
+ os=-linux
+ ;;
m88k-omron*)
basic_machine=m88k-omron
;;
@@ -813,6 +833,14 @@ case $basic_machine in
basic_machine=i860-intel
os=-osf
;;
+ parisc)
+ basic_machine=hppa-unknown
+ os=-linux
+ ;;
+ parisc-*)
+ basic_machine=hppa-`echo $basic_machine | sed 's/^[^-]*-//'`
+ os=-linux
+ ;;
pbd)
basic_machine=sparc-tti
;;
@@ -1021,6 +1049,10 @@ case $basic_machine in
basic_machine=tic6x-unknown
os=-coff
;;
+ tile*)
+ basic_machine=tile-unknown
+ os=-linux-gnu
+ ;;
tx39)
basic_machine=mipstx39-unknown
;;
diff --git a/debian/changelog b/debian/changelog
index ad3b9e1..3ad1d30 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,10 @@
-cscope (15.6-6) UNRELEASED; urgency=low
+cscope (15.6-6) unstable; urgency=low
+ * Fix Bashisms in contrib/ocs (Closes: #480591)
* Remove Homepage tag in control in favour of the new control field.
* Add Vcs-Git and Vcs-Browser control fields.
- -- Tobias Klauser <tklauser@access.unizh.ch> Sat, 26 Jan 2008 18:38:05 +0100
+ -- Tobias Klauser <tklauser@access.unizh.ch> Sun, 18 May 2008 19:43:23 +0200
cscope (15.6-5) unstable; urgency=low
diff --git a/debian/patches/00list b/debian/patches/00list
index 6e04a66..33327d1 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,2 +1,3 @@
01-fix-resize-crash-inside-vim
02-fix-xcscope-el-typo
+03-fix-ocs-bashisms.dpatch
diff --git a/debian/patches/03-fix-ocs-bashisms.dpatch b/debian/patches/03-fix-ocs-bashisms.dpatch
new file mode 100755
index 0000000..01cd011
--- /dev/null
+++ b/debian/patches/03-fix-ocs-bashisms.dpatch
@@ -0,0 +1,67 @@
+#!/bin/sh /usr/share/dpatch/dpatch-run
+## 03-fix-ocs-bashisms.dpatch
+##
+## DP: Fixes bashims in ocs
+## DP: (Closes: #480591)
+
+--- a/contrib/ocs
++++ b/contrib/ocs
+@@ -87,7 +87,7 @@ if [ ! -d ${SYSDIR} ]; then
+ fi
+
+ # Check that cscope is in PATH
+-type cscope 1>/dev/null 2>&1
++which cscope 1>/dev/null 2>&1
+
+ if [ $? -ne 0 ]
+ then
+@@ -168,8 +168,8 @@ create_list()
+
+ if [ "${FORCE}" != "Y" ]
+ then
+- echo "\n${LIST}"
+- echo "Update the library? <(Y)es, (N)o, (Q)uit> [n] \c"
++ printf "\n${LIST}\n"
++ printf "Update the library? <(Y)es, (N)o, (Q)uit> [n] "
+ read x y
+ case $x in
+ [Yy]* ) ;;
+@@ -177,9 +177,9 @@ create_list()
+ *) return ;;
+ esac
+ fi
+- echo "Updating library:\n ${LIST} \c"
++ printf "Updating library:\n ${LIST} "
+ else
+- echo "Creating library:\n ${LIST} \c"
++ printf "Creating library:\n ${LIST} "
+ fi
+
+ (
+@@ -197,7 +197,7 @@ create_list()
+ -print
+ ) | grep -v SCCS | sort -u > ${LIST}
+
+- echo "\n`cat ${LIST} | wc -l` files listed"
++ printf "\n`cat ${LIST} | wc -l` files listed\n"
+ }
+
+ #
+@@ -211,7 +211,7 @@ exp_inc()
+ then
+ for i in `cat ${theInc}`
+ do
+- echo "-I $i \c"
++ printf "-I $i "
+ done
+ fi
+ }
+@@ -286,7 +286,7 @@ std_libs ${SYSDIR}$PWD
+
+ DIR=$PWD
+ if [ ! -n "${NOUPDATE}" -o -n "${SPECDEST}" ] ; then
+-echo "Create new library? <(L)ocal, (H)ome, (S)ystem, (Q)uit> [q] \c"
++printf "Create new library? <(L)ocal, (H)ome, (S)ystem, (Q)uit> [q] "
+ read x y
+ case $x in
+ [Ll]* ) DIR=$PWD ;;