summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTobias Klauser <tklauser@distanz.ch>2006-11-13 22:13:33 +0100
committerTobias Klauser <tklauser@xenon.tklauser.home>2006-11-13 22:13:33 +0100
commitb37e0da0b7dc72ddfa513e319ca71b5f5b8aeb7d (patch)
tree810ec4a83a30b7e001321fdb2402c756f511727e /debian/rules
Initial import15.6-2
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules92
1 files changed, 92 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..969ccc2
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,92 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpatch/dpatch.make
+
+DEST = $(CURDIR)/debian/cscope
+
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+config.status: patch-stamp configure
+ dh_testdir
+ CFLAGS="$(CFLAGS) -Wl,-z,defs" ./configure --host=$(DEB_HOST_GNU_TYPE) \
+ --build=$(DEB_BUILD_GNU_TYPE) \
+ --prefix=/usr \
+ --mandir=\$${prefix}/share/man \
+ --infodir=\$${prefix}/share/info
+
+
+build: build-stamp
+
+build-stamp: config.status
+ dh_testdir
+
+ $(MAKE)
+
+ touch build-stamp
+
+clean: unpatch
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ -$(MAKE) distclean
+
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs usr/share/emacs/site-lisp
+
+ $(MAKE) install DESTDIR=$(DEST)
+
+ # Install xcscope
+ install -m755 -p contrib/xcscope/cscope-indexer $(DEST)/usr/bin/
+ install -m644 -p contrib/xcscope/xcscope.el $(DEST)/usr/share/emacs/site-lisp/
+
+binary-indep: build install
+# We have nothing to do by default.
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs AUTHORS NEWS README TODO
+ dh_installman debian/ocs.1 debian/cscope-indexer.1
+ install -d $(DEST)/usr/share/doc/cscope/contrib/webcscope
+ cp -av contrib/README $(DEST)/usr/share/doc/cscope/contrib
+ cp -av contrib/webcscope/cgi-lib.pl contrib/webcscope/cscope \
+ contrib/webcscope/hilite.c contrib/webcscope/icons \
+ contrib/webcscope/INSTALL contrib/webcscope/TODO \
+ $(DEST)/usr/share/doc/cscope/contrib/webcscope
+ # Prevent CVS metadata from being installed
+ find $(DEST)/usr/share/doc/cscope/contrib/webcscope -type d -name CVS | xargs rm -rf
+ dh_installmenu
+ dh_installemacsen
+ dh_installchangelogs ChangeLog
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install