summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authortony mancill <tmancill@debian.org>2010-06-03 13:40:55 +0200
committerTobias Klauser <tklauser@distanz.ch>2010-06-03 13:40:55 +0200
commit2532a731d79ab37ac27c17fb84b6017a7f1ae4cb (patch)
treed3dfc2464b2db0d3522538c8013269dab9ebc3cf /debian/rules
parentc3ca49de5b937873d599ce862ae1f365499f8bfb (diff)
Bug#565727: cscope: diff for NMU version 15.7a-3.1
tags 565727 + pending thanks Dear maintainer, I've prepared an NMU for cscope (versioned as 15.7a-3.1) and uploaded it to DELAYED/3. Please feel free to tell me if I should delay it longer. Regards, Tony
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules100
1 files changed, 7 insertions, 93 deletions
diff --git a/debian/rules b/debian/rules
index c0d4f44..881719b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,99 +1,13 @@
#!/usr/bin/make -f
-include /usr/share/dpatch/dpatch.make
-
-DEST = $(CURDIR)/debian/cscope
-
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-confflags =
-ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
- confflags += --build $(DEB_HOST_GNU_TYPE)
-else
- confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
-endif
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-config.status: patch-stamp configure
- dh_testdir
-
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess config.guess
-endif
-
- CFLAGS="$(CFLAGS) -Wl,-z,defs" ./configure $(confflags) \
- --prefix=/usr \
- --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
-
- $(MAKE)
-
- touch build-stamp
-
-clean: unpatch
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- [ ! -f Makefile ] || $(MAKE) distclean
- rm -f config.sub config.guess
+override_dh_auto_install:
+ # Disabled. See debian/*.install files
+override_dh_clean:
dh_clean
+ find -type d -name CVS | xargs --no-run-if-empty rm -rf
+%:
+ dh $@
-install: build
- dh_testdir
- dh_testroot
- dh_prep
-
- $(MAKE) install DESTDIR=$(DEST)
-
- # Install xcscope
- install -m755 -p contrib/xcscope/cscope-indexer $(DEST)/usr/bin/
-
-binary-indep: build install
-# We have nothing to do by default.
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_install
- dh_installdocs AUTHORS NEWS README TODO
- dh_installman debian/ocs.1 debian/cscope-indexer.1
- install -d $(DEST)/usr/share/doc/cscope/contrib/webcscope
- cp -av contrib/README $(DEST)/usr/share/doc/cscope/contrib
- cp -av contrib/webcscope/cgi-lib.pl contrib/webcscope/cscope \
- contrib/webcscope/hilite.c contrib/webcscope/icons \
- contrib/webcscope/INSTALL contrib/webcscope/TODO \
- $(DEST)/usr/share/doc/cscope/contrib/webcscope
- # Prevent CVS metadata from being installed
- find $(DEST)/usr/share/doc/cscope/contrib/webcscope -type d -name CVS | xargs rm -rf
- dh_installmenu
- dh_installemacsen
- dh_installchangelogs ChangeLog
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+# End of file
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install