summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTobias Klauser <tklauser@distanz.ch>2008-05-18 19:44:14 +0200
committerTobias Klauser <tklauser@xenon.tklauser.home>2008-05-18 19:44:14 +0200
commitd547fc2a1be23e18c34eb189150ef55db8bc5c56 (patch)
tree63b85d572e34e6ba1f7c18c4f57f889236e9297f /debian
parentb98e8def5fe980cd6fccb24ecaf6daaa28663234 (diff)
Fix Bashisms in contrib/ocs (Closes: #480591)15.6-6
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/03-fix-ocs-bashisms.dpatch67
3 files changed, 71 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index ad3b9e1..3ad1d30 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,10 @@
-cscope (15.6-6) UNRELEASED; urgency=low
+cscope (15.6-6) unstable; urgency=low
+ * Fix Bashisms in contrib/ocs (Closes: #480591)
* Remove Homepage tag in control in favour of the new control field.
* Add Vcs-Git and Vcs-Browser control fields.
- -- Tobias Klauser <tklauser@access.unizh.ch> Sat, 26 Jan 2008 18:38:05 +0100
+ -- Tobias Klauser <tklauser@access.unizh.ch> Sun, 18 May 2008 19:43:23 +0200
cscope (15.6-5) unstable; urgency=low
diff --git a/debian/patches/00list b/debian/patches/00list
index 6e04a66..33327d1 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,2 +1,3 @@
01-fix-resize-crash-inside-vim
02-fix-xcscope-el-typo
+03-fix-ocs-bashisms.dpatch
diff --git a/debian/patches/03-fix-ocs-bashisms.dpatch b/debian/patches/03-fix-ocs-bashisms.dpatch
new file mode 100755
index 0000000..01cd011
--- /dev/null
+++ b/debian/patches/03-fix-ocs-bashisms.dpatch
@@ -0,0 +1,67 @@
+#!/bin/sh /usr/share/dpatch/dpatch-run
+## 03-fix-ocs-bashisms.dpatch
+##
+## DP: Fixes bashims in ocs
+## DP: (Closes: #480591)
+
+--- a/contrib/ocs
++++ b/contrib/ocs
+@@ -87,7 +87,7 @@ if [ ! -d ${SYSDIR} ]; then
+ fi
+
+ # Check that cscope is in PATH
+-type cscope 1>/dev/null 2>&1
++which cscope 1>/dev/null 2>&1
+
+ if [ $? -ne 0 ]
+ then
+@@ -168,8 +168,8 @@ create_list()
+
+ if [ "${FORCE}" != "Y" ]
+ then
+- echo "\n${LIST}"
+- echo "Update the library? <(Y)es, (N)o, (Q)uit> [n] \c"
++ printf "\n${LIST}\n"
++ printf "Update the library? <(Y)es, (N)o, (Q)uit> [n] "
+ read x y
+ case $x in
+ [Yy]* ) ;;
+@@ -177,9 +177,9 @@ create_list()
+ *) return ;;
+ esac
+ fi
+- echo "Updating library:\n ${LIST} \c"
++ printf "Updating library:\n ${LIST} "
+ else
+- echo "Creating library:\n ${LIST} \c"
++ printf "Creating library:\n ${LIST} "
+ fi
+
+ (
+@@ -197,7 +197,7 @@ create_list()
+ -print
+ ) | grep -v SCCS | sort -u > ${LIST}
+
+- echo "\n`cat ${LIST} | wc -l` files listed"
++ printf "\n`cat ${LIST} | wc -l` files listed\n"
+ }
+
+ #
+@@ -211,7 +211,7 @@ exp_inc()
+ then
+ for i in `cat ${theInc}`
+ do
+- echo "-I $i \c"
++ printf "-I $i "
+ done
+ fi
+ }
+@@ -286,7 +286,7 @@ std_libs ${SYSDIR}$PWD
+
+ DIR=$PWD
+ if [ ! -n "${NOUPDATE}" -o -n "${SPECDEST}" ] ; then
+-echo "Create new library? <(L)ocal, (H)ome, (S)ystem, (Q)uit> [q] \c"
++printf "Create new library? <(L)ocal, (H)ome, (S)ystem, (Q)uit> [q] "
+ read x y
+ case $x in
+ [Ll]* ) DIR=$PWD ;;