summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rw-r--r--debian/cscope.preinst24
3 files changed, 32 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6283f18..cfa3906 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+cscope (15.6-5) unstable; urgency=low
+
+ * Remove left over Emacs startup file (Closes: #454377)
+ * Update to Standards-Version 3.7.3 (no changes needed)
+
+ -- Tobias Klauser <tklauser@access.unizh.ch> Thu, 06 Dec 2007 20:06:00 +0100
+
cscope (15.6-4) unstable; urgency=low
* Fix a typo in xcscope.el (Closes: #438170)
diff --git a/debian/control b/debian/control
index 14493b3..4f3ae41 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Tobias Klauser <tklauser@access.unizh.ch>
Build-Depends: debhelper (>= 5), dpatch, autotools-dev, bison, flex, libncurses5-dev
-Standards-Version: 3.7.2
+Standards-Version: 3.7.3
Package: cscope
Architecture: any
diff --git a/debian/cscope.preinst b/debian/cscope.preinst
new file mode 100644
index 0000000..be518b4
--- /dev/null
+++ b/debian/cscope.preinst
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+cleanup_sitestart() {
+ if [ -e /etc/emacs/site-start.d/50cscope.el ]; then
+ rm -f /etc/emacs/site-start.d/50cscope.el
+ fi
+}
+
+case "$1" in
+ upgrade)
+ cleanup_sitestart
+ ;;
+
+ install|abort-upgrade)
+ ;;
+
+ *)
+ echo "$0 called with unknown argument '$1'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+exit 0