#!/usr/bin/make -f include /usr/share/dpatch/dpatch.make DEST = $(CURDIR)/debian/cscope DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) CFLAGS = -Wall -g ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) CFLAGS += -O0 else CFLAGS += -O2 endif config.status: patch-stamp configure dh_testdir CFLAGS="$(CFLAGS) -Wl,-z,defs" ./configure --host=$(DEB_HOST_GNU_TYPE) \ --build=$(DEB_BUILD_GNU_TYPE) \ --prefix=/usr \ --mandir=\$${prefix}/share/man \ --infodir=\$${prefix}/share/info build: build-stamp build-stamp: config.status dh_testdir $(MAKE) touch build-stamp clean: unpatch dh_testdir dh_testroot rm -f build-stamp [ ! -f Makefile ] || $(MAKE) distclean ifneq "$(wildcard /usr/share/misc/config.sub)" "" cp -f /usr/share/misc/config.sub config.sub endif ifneq "$(wildcard /usr/share/misc/config.guess)" "" cp -f /usr/share/misc/config.guess config.guess endif dh_clean install: build dh_testdir dh_testroot dh_prep $(MAKE) install DESTDIR=$(DEST) # Install xcscope install -m755 -p contrib/xcscope/cscope-indexer $(DEST)/usr/bin/ binary-indep: build install # We have nothing to do by default. binary-arch: build install dh_testdir dh_testroot dh_install dh_installdocs AUTHORS NEWS README TODO dh_installman debian/ocs.1 debian/cscope-indexer.1 install -d $(DEST)/usr/share/doc/cscope/contrib/webcscope cp -av contrib/README $(DEST)/usr/share/doc/cscope/contrib cp -av contrib/webcscope/cgi-lib.pl contrib/webcscope/cscope \ contrib/webcscope/hilite.c contrib/webcscope/icons \ contrib/webcscope/INSTALL contrib/webcscope/TODO \ $(DEST)/usr/share/doc/cscope/contrib/webcscope # Prevent CVS metadata from being installed find $(DEST)/usr/share/doc/cscope/contrib/webcscope -type d -name CVS | xargs rm -rf dh_installmenu dh_installemacsen dh_installchangelogs ChangeLog dh_strip dh_compress dh_fixperms dh_installdeb dh_shlibdeps dh_gencontrol dh_md5sums dh_builddeb binary: binary-indep binary-arch .PHONY: build clean binary-indep binary-arch binary install href='/cgit.cgi/linux/net-next.git/diff/Makefile?h=packet-loop-back&id=4c3b73c6a2eea0cf27fb058086a0eb94e90bffd4'>diff
path: root/Makefile
diff options
context:
space:
mode:
authorLinus Torvalds <torvalds@linux-foundation.org>2016-04-03 07:22:12 -0500
committerLinus Torvalds <torvalds@linux-foundation.org>2016-04-03 07:22:12 -0500
commit4c3b73c6a2eea0cf27fb058086a0eb94e90bffd4 (patch)
tree2add808dc63a3f6ec461a95af7ddc6e7a117a331 /Makefile
parent7b367f5dba5c5162a7308e85d3fc9170b0cb3e5f (diff)
parent85dc600263c2291cea33bffa90038808ee64198b (diff)
Merge branch 'perf-urgent-for-linus' of git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip
Pull perf fixes from Ingo Molnar: "Misc kernel side fixes: - fix event leak - fix AMD PMU driver bug - fix core event handling bug - fix build bug on certain randconfigs Plus misc tooling fixes" * 'perf-urgent-for-linus' of git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip: perf/x86/amd/ibs: Fix pmu::stop() nesting perf/core: Don't leak event in the syscall error path perf/core: Fix time tracking bug with multiplexing perf jit: genelf makes assumptions about endian perf hists: Fix determination of a callchain node's childlessness perf tools: Add missing initialization of perf_sample.cpumode in synthesized samples perf tools: Fix build break on powerpc perf/x86: Move events_sysfs_show() outside CPU_SUP_INTEL perf bench: Fix detached tarball building due to missing 'perf bench memcpy' headers perf tests: Fix tarpkg build test error output redirection
Diffstat (limited to 'Makefile')