summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorTobias Klauser <tklauser@distanz.ch>2007-06-20 15:21:47 +0200
committerTobias Klauser <tklauser@xenon.tklauser.home>2007-06-20 15:21:47 +0200
commit80a71e08f368bde5add474dd7d9d497ecd835532 (patch)
tree87459ca64ab424c96864b3755d4c96f2d3d0fe1a /Makefile
parentad7e695784296d9e4058ebe5e27a20864076f53b (diff)
New upstream release0.4-1
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index cfeb89a..bcb8cd4 100644
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,7 @@
#
# Licensed under the terms of the GNU General Public License; version 2 or later.
-VERSION = 0.3
+VERSION = 0.4
# Paths
prefix = /usr/local
@@ -12,7 +12,7 @@ BINDIR = $(prefix)/bin
MANDIR = $(prefix)/share/man/man1
CC := gcc
-CFLAGS := $(CFLAGS) -W -Wall -pipe -D_USE_SOURCE -DVERSION="\"$(VERSION)\"" \
+CFLAGS := $(CFLAGS) -pipe -D_USE_SOURCE -DVERSION="\"$(VERSION)\"" -W -Wall \
-Wstrict-prototypes -Wsign-compare -Wshadow -Wchar-subscripts \
-Wmissing-declarations -Wpointer-arith -Wcast-align -Wmissing-prototypes
@@ -31,6 +31,10 @@ inotail: inotail.o
install: inotail
install -m 775 -D inotail $(BINDIR)/inotail
install -m 644 -D inotail.1 $(MANDIR)/inotail.1
+ gzip -9 $(MANDIR)/inotail.1
+
+uninstall:
+ rm $(BINDIR)/inotail $(MANDIR)/inotail.1*
cscope:
cscope -b