summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules49
1 files changed, 4 insertions, 45 deletions
diff --git a/debian/rules b/debian/rules
index 786c709..1fd8c5b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,48 +1,7 @@
#!/usr/bin/make -f
-build: build-stamp
-build-stamp:
- dh_testdir
+%:
+ dh ${@}
- $(MAKE)
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- $(MAKE) clean
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
-
- $(MAKE) install prefix=$(CURDIR)/debian/inotail/usr
-
-binary-indep: build install
-# We have nothing to do by default.
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs changelog
- dh_installdocs
- dh_install
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_install:
+ dh_auto_install -- prefix=$(CURDIR)/debian/inotail/usr