summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTobias Klauser <tklauser@distanz.ch>2008-10-08 19:40:31 +0200
committerTobias Klauser <tklauser@xenon.tklauser.home>2008-10-08 19:40:31 +0200
commit474c496e8851e4f940abab0dc7aeea7fe7dabcf9 (patch)
tree95d1099f6b97b11450ee0c79419d907832af6355 /debian/rules
parent2a441ecbea378da1a2cdea969c48bb7d9e547135 (diff)
Adapt package to new source layout.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 7 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 3e148bf..0a474b9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,11 +2,13 @@
include /usr/share/dpatch/dpatch.make
+SRCDIR=src
+
configure: configure-stamp
configure-stamp: patch-stamp
dh_testdir
- qmake-qt4 lfhex.pro
+ cd $(SRCDIR) && qmake-qt4 lfhex.pro
touch configure-stamp
@@ -15,7 +17,7 @@ build: build-stamp
build-stamp: configure-stamp
dh_testdir
- $(MAKE)
+ cd $(SRCDIR) && $(MAKE)
touch $@
@@ -24,8 +26,8 @@ clean: unpatch
dh_testroot
rm -f build-stamp configure-stamp
- [ ! -f Makefile ] || $(MAKE) clean
- rm -f Makefile lfhex
+ cd $(SRCDIR) && ([ ! -f Makefile ] || $(MAKE) clean)
+ rm -f $(SRCDIR)/Makefile $(SRCDIR)/lfhex
dh_clean
@@ -37,7 +39,7 @@ install: build
# Do a manual install, qmake does not correctly generate an install
# target
- install -D -m755 -p lfhex $(CURDIR)/debian/lfhex/usr/bin/lfhex
+ cd $(SRCDIR) && install -D -m755 -p lfhex $(CURDIR)/debian/lfhex/usr/bin/lfhex
# Build architecture-independent files here.
binary-indep: