summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTobias Klauser <tklauser@distanz.ch>2008-07-01 16:45:28 +0200
committerTobias Klauser <tklauser@xenon.tklauser.home>2008-07-01 16:45:28 +0200
commit2ada69fe971ecc8881d5eb01dfbf337996472c40 (patch)
treecfb5e62fb3b48399770c292ab73e0b16698de366 /debian
Initial import
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control15
-rw-r--r--debian/copyright33
-rw-r--r--debian/docs1
-rw-r--r--debian/lfhex.125
-rwxr-xr-xdebian/rules62
-rw-r--r--debian/watch2
8 files changed, 144 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..3ae4baf
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+lfhex (0.4-1) unstable; urgency=low
+
+ * Initial release (Closes: #483159, #483165)
+
+ -- Tobias Klauser <tklauser@access.unizh.ch> Tue, 27 May 2008 19:49:49 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..1e8b314
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+6
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..2b11c65
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,15 @@
+Source: lfhex
+Section: editors
+Priority: optional
+Maintainer: Tobias Klauser <tklauser@access.unizh.ch>
+Build-Depends: debhelper (>= 6), libqt4-dev, flex, bison
+Standards-Version: 3.8.0
+Homepage: http://stoopidsimple.com/lfhex
+
+Package: lfhex
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: large file hex editor
+ lfhex is an application for viewing and editing files in hex, octal,
+ binary, or ascii text. The main strength of lfhex is its ability to
+ work with files much larger than system memory or address space.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..688ba79
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,33 @@
+This package was debianized by Tobias Klauser <tklauser@access.unizh.ch> on
+Tue, 27 May 2008 18:56:54 +0200.
+
+It was downloaded from <http://stoopidsimple.com/lfhex>.
+
+Upstream Author:
+
+ Salem Ganzhorn <eyekode@yahoo.com>
+
+Copyright:
+
+ Copyright (C) 2006 Salem Ganzhorn
+
+License:
+
+ This program is free software; you can redistribute it and/or
+ modify it under the terms of the GNU General Public License
+ as published by the Free Software Foundation version 2.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in /usr/share/common-licenses/GPL file.
+
+The Debian packaging is (C) 2008, Tobias Klauser <tklauser@access.unizh.ch> and
+is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e845566
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README
diff --git a/debian/lfhex.1 b/debian/lfhex.1
new file mode 100644
index 0000000..199b1d2
--- /dev/null
+++ b/debian/lfhex.1
@@ -0,0 +1,25 @@
+.TH LFHEX 1 "May 27, 2008"
+.SH NAME
+lfhex \- Large File Hex Editor
+.SH SYNOPSIS
+.B lfhex
+.RI [ options ] " files" ...
+.SH DESCRIPTION
+\fBlfhex\fP is an application for viewing and editing files in hex, octal,
+binary, or ascii text. The main strength of lfhex is its ability to work with
+files much larger than system memory or address space.
+.SH OPTIONS
+.B \-c \fIfile1\fR \fIfile2\fR
+Start lfhex in compare mode
+.PP
+lfhex supports some traditional X11 command line options supported through Qt's
+QApplication class. See
+\fBhttp://doc.trolltech.com/4.1/qapplication.html#QApplication for details.\fP
+.SH SEE ALSO
+.PP
+The lfhex manual at: \fBhttp://stoopidsimple.com/lfhex/manual\fP
+.SH AUTHOR
+lfhex was written by Salem Ganzhorn <eyekode@yahoo.com>.
+.PP
+This manual page was written by Tobias Klauser <tklauser@access.unizh.ch>,
+for the Debian project (but may be used by others).
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9111682
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,62 @@
+#!/usr/bin/make -f
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+
+ qmake lfhex.pro
+
+ touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ $(MAKE)
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ [ ! -f Makefile ] || $(MAKE) clean
+ rm -f Makefile lfhex
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Do a manual install, qmake does not correctly generate an install
+ # target
+ install -D -m755 -p lfhex $(CURDIR)/debian/lfhex/usr/bin/lfhex
+
+# Build architecture-independent files here.
+binary-indep:
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installchangelogs
+ dh_installman debian/lfhex.1
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..a0bc5e3
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,2 @@
+version=3
+http://stoopidsimple.com/files/lfhex-(.*)\.tar\.gz