summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/01-abs-llabs.dpatch19
-rwxr-xr-xdebian/rules4
4 files changed, 28 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index d3b03b2..1b345fa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+lfhex (0.4-3) unstable; urgency=low
+
+ * Actually apply the patch to fix FTBFS. Closes: #495467 for real this time.
+
+ -- Tobias Klauser <tklauser@access.unizh.ch> Mon, 08 Sep 2008 21:55:59 +0200
+
lfhex (0.4-2) unstable; urgency=low
* Fix FTBFS caused by abs not being in the global namespace anymore on some
diff --git a/debian/patches/00list b/debian/patches/00list
new file mode 100644
index 0000000..6b7bc42
--- /dev/null
+++ b/debian/patches/00list
@@ -0,0 +1 @@
+01-abs-llabs.dpatch
diff --git a/debian/patches/01-abs-llabs.dpatch b/debian/patches/01-abs-llabs.dpatch
new file mode 100755
index 0000000..7515266
--- /dev/null
+++ b/debian/patches/01-abs-llabs.dpatch
@@ -0,0 +1,19 @@
+#!/bin/sh /usr/share/dpatch/dpatch-run
+## 01-abs-llabs.dpatch by Thiemo Seufer
+##
+## DP: Fixes FTBFS due to abs() not being in the global anymore since g++ 4.3
+## (#495467)
+
+diff -up lfhex-0.4.orig/reader.cpp lfhex-0.4/reader.cpp
+--- lfhex-0.4.orig/reader.cpp 2006-11-05 04:26:04.000000000 +0000
++++ lfhex-0.4/reader.cpp 2008-08-16 22:43:44.000000000 +0100
+@@ -238,7 +238,7 @@ bool Reader::loadPage(off_t pageIdx)
+ // free the page which is the furthest away from the page we are loading
+
+ // this could be trouble if off_t is unsigned!
+- if( abs(_firstPage - pageIdx) > abs(_lastPage - pageIdx) )
++ if( ::llabs(_firstPage - pageIdx) > ::llabs(_lastPage - pageIdx) )
+ while(!freePage(_firstPage++));
+ else
+ while(!freePage(_lastPage--));
+
diff --git a/debian/rules b/debian/rules
index 238c1c5..859350d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,8 +2,8 @@
include /usr/share/dpatch/dpatch.make
-configure: patch-stamp configure-stamp
-configure-stamp:
+configure: configure-stamp
+configure-stamp: patch-stamp
dh_testdir
qmake lfhex.pro