summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Klauser <tklauser@distanz.ch>2012-12-14 14:37:36 +0100
committerTobias Klauser <tklauser@distanz.ch>2012-12-14 14:37:36 +0100
commit525a852884c24ea0282759d9a8f2363184d5686d (patch)
treeac48ea5001e499a391ef436cb9fd23797f19a057 /CMakeLists.txt
parentb59ea8252fa65d1000acd9d1c866c99cc2de3d71 (diff)
CMakeLists.txt: Set Target name and extend library path to work on Linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 636cd94..8d379a4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,7 @@ SET(OPENSIM_INSTALL_DIR $ENV{OPENSIM_HOME}
CACHE PATH "Top-level directory of OpenSim install")
# Change name of build target
-SET(TARGET exampleMain CACHE TYPE STRING)
+SET(TARGET LocomotorPrimitives CACHE TYPE STRING)
# Identify the cpp file(s) that were to be built
FILE(GLOB SOURCE_FILES *.h *.cpp)
SET(SOURCE ${SOURCE_FILES})
@@ -28,6 +28,7 @@ SET(OPENSIM_HEADERS_DIR ${OPENSIM_INSTALL_DIR}/sdk/include)
INCLUDE_DIRECTORIES(${SIMTK_HEADERS_DIR} ${OPENSIM_HEADERS_DIR})
# Libraries and dlls
SET(OPENSIM_LIBS_DIR ${OPENSIM_INSTALL_DIR}/sdk/lib)
+SET(OPENSIM_LIBS_DIR ${OPENSIM_INSTALL_DIR}/lib)
SET(OPENSIM_DLLS_DIR ${OPENSIM_INSTALL_DIR}/bin)
LINK_DIRECTORIES(${OPENSIM_LIBS_DIR} ${OPENSIM_DLLS_DIR})