summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Meskes <meskes@debian.org>2008-08-27 13:45:17 +0200
committerMichael Meskes <meskes@debian.org>2008-08-27 13:45:17 +0200
commitf06a98f0b468601fc1ab929b06a7962cca8614ea (patch)
treed1e64a0785f80b753f11d81a77f9cb27f86dcf0a
Imported Upstream version 0.1
-rw-r--r--Makefile24
-rw-r--r--at.c162
-rw-r--r--emit.c193
-rw-r--r--emit.h4
-rw-r--r--error.c20
-rw-r--r--error.h1
-rw-r--r--license.txt280
-rw-r--r--readme.txt27
-rw-r--r--sched.c25
-rw-r--r--sched.h21
10 files changed, 757 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..8d8c490
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
+VERSION=0.1
+
+DEBUG=-g #-fprofile-arcs -ftest-coverage # -pg -g
+CFLAGS+=-Wall -O2 -DVERSION=\"${VERSION}\" $(DEBUG)
+LDFLAGS+=-lacpi $(DEBUG)
+
+OBJS=error.o at.o sched.o emit.o
+
+all: acpitail
+
+acpitail: $(OBJS)
+ $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o acpitail
+
+install: acpitail
+ cp acpitail /usr/local/sbin
+
+clean:
+ rm -f $(OBJS) acpitail core *.da *.gcov *.bb*
+
+package: clean
+ mkdir acpitail-$(VERSION)
+ cp *.c *.h Makefile readme.txt license.txt acpitail-$(VERSION)
+ tar czf acpitail-$(VERSION).tgz acpitail-$(VERSION)
+ rm -rf acpitail-$(VERSION)
diff --git a/at.c b/at.c
new file mode 100644
index 0000000..1babd83
--- /dev/null
+++ b/at.c
@@ -0,0 +1,162 @@
+#include <string.h>
+#include <time.h>
+#include <stdio.h>
+#include <stdlib.h>
+#include <unistd.h>
+#include <libacpi.h>
+
+#include "error.h"
+#include "sched.h"
+#include "emit.h"
+
+sched_t scheds[N_SCHED + 1] = {
+ { SCHED_BATT, 0, DI_BATT },
+ { SCHED_ACSTATE, 0, DI_ACSTATE },
+ { SCHED_ZONE, 0, DI_ZONE },
+ { SCHED_FAN, 0, DI_FAN},
+ { -1, -1, -1 }
+};
+
+int get_interval(int what, sched_t *scheds)
+{
+ int index = 0;
+
+ while(scheds[index].what != -1)
+ {
+ if (scheds[index].what == what)
+ return scheds[index].interval;
+
+ index++;
+ }
+
+ return -1;
+}
+
+void set_interval(int what, sched_t *scheds, int value)
+{
+ int index = 0;
+
+ while(scheds[index].what != -1)
+ {
+ if (scheds[index].what == what)
+ {
+ scheds[index].interval = value;
+ }
+
+ index++;
+ }
+}
+
+void version(void)
+{
+ printf("acpitail v" VERSION ", (C) 2007 by folkert@vanheusden.com\n\n");
+}
+
+void help(void)
+{
+ version();
+
+ printf("-A x set check interval for AC-state (default: %ds)\n", get_interval(SCHED_ACSTATE, scheds));
+ printf("-B x interval for battery (%d)\n", get_interval(SCHED_BATT, scheds));
+ printf("-F x interval for fans (%d)\n", get_interval(SCHED_FAN, scheds));
+ printf("-Z x interval for zone information (%d)\n", get_interval(SCHED_ZONE, scheds));
+ printf("-h this help\n");
+ printf("-V show version information\n");
+}
+
+int main(int argc, char *argv[])
+{
+ global_t globals;
+ int c;
+
+ while((c = getopt(argc, argv, "B:A:Z:F:")) != -1)
+ {
+ switch(c)
+ {
+ case 'B':
+ set_interval(SCHED_BATT, scheds, atoi(optarg));
+ break;
+
+ case 'A':
+ set_interval(SCHED_ACSTATE, scheds, atoi(optarg));
+ break;
+
+ case 'Z':
+ set_interval(SCHED_ZONE, scheds, atoi(optarg));
+ break;
+
+ case 'F':
+ set_interval(SCHED_FAN, scheds, atoi(optarg));
+ break;
+
+ case 'V':
+ version();
+ return 0;
+
+ case 'h':
+ help();
+ return 0;
+
+ default:
+ help();
+ return 1;
+ }
+ }
+
+ if (check_acpi_support() == NOT_SUPPORTED)
+ error_exit("This system does not support ACPI.\n");
+
+ memset(&globals, 0x00, sizeof(globals));
+
+ if (init_acpi_batt(&globals) == ALLOC_ERR)
+ error_exit("Failed to obtain battery information.\n");
+
+ if (init_acpi_acadapt(&globals) == ALLOC_ERR)
+ error_exit("Failed to obtain AC adapter information.\n");
+
+ if (init_acpi_thermal(&globals) == ALLOC_ERR)
+ error_exit("Failed to obtain thermal areas information.\n");
+
+ if (init_acpi_fan(&globals) == ALLOC_ERR)
+ error_exit("Failed to obtain fan information.\n");
+
+ for(;;)
+ {
+ int loop;
+ char header_shown = 0;
+
+ for(loop=0; loop<N_SCHED; loop++)
+ {
+ time_t now = time(NULL);
+ time_t cur_next_event = scheds[loop].last_run + scheds[loop].interval;
+
+ if (cur_next_event <= now)
+ {
+ switch(scheds[loop].what)
+ {
+ case SCHED_BATT:
+ emit_battery(&globals, &header_shown);
+ break;
+
+ case SCHED_ACSTATE:
+ emit_acstate(&globals, &header_shown);
+ break;
+
+ case SCHED_ZONE:
+ emit_zone(&globals, &header_shown);
+ break;
+
+ case SCHED_FAN:
+ emit_fan(&globals, &header_shown);
+ break;
+ }
+
+ scheds[loop].last_run = now;
+ }
+ }
+
+ sleep_untill_next_event(scheds, N_SCHED);
+ }
+
+ return 0;
+}
diff --git a/emit.c b/emit.c
new file mode 100644
index 0000000..5e16664
--- /dev/null
+++ b/emit.c
@@ -0,0 +1,193 @@
+#include <stdio.h>
+#include <time.h>
+#include <string.h>
+#include <stdlib.h>
+#include <libacpi.h>
+
+#include "error.h"
+
+
+void emit_ts(void)
+{
+ time_t now = time(NULL);
+
+ printf("%s", ctime(&now));
+}
+
+void header(char *header_shown)
+{
+ if (!*header_shown)
+ {
+ emit_ts();
+ *header_shown = 1;
+ }
+}
+
+void emit_battery(global_t *globals, char *header_shown)
+{
+ int loop;
+ static int *prevs = NULL;
+
+ if (!prevs)
+ {
+ int bytes = sizeof(int) * globals -> batt_count;
+ prevs = malloc(bytes);
+ memset(prevs, 0x00, bytes);
+ }
+
+ for(loop=0; loop<globals -> batt_count; loop++)
+ {
+ int rc = read_acpi_batt(loop);
+
+ if (rc == ITEM_EXCEED)
+ break;
+ if (rc == ALLOC_ERR)
+ error_exit("reac_acpi_batt(%d) failed\n", loop);
+
+ if (prevs[loop] != batteries[loop].percentage)
+ {
+ header(header_shown);
+ printf("%s remaining capacity: %d%% (%d minutes)\n", batteries[loop].name, batteries[loop].percentage, batteries[loop].remaining_time);
+ prevs[loop] = batteries[loop].percentage;
+ }
+ }
+}
+
+char * power_state_str(power_state_t ps)
+{
+ switch(ps)
+ {
+ case P_AC:
+ return "AC";
+
+ case P_BATT:
+ return "batteries";
+
+ case P_ERR:
+ return "error";
+ }
+
+ return "?";
+}
+
+void emit_acstate(global_t *globals, char *header_shown)
+{
+ static int prev_state = -1;
+
+ read_acpi_acstate(globals);
+
+ if (prev_state != globals -> adapt.ac_state)
+ {
+ header(header_shown);
+ printf("Adapter %s: %s\n", globals -> adapt.name, power_state_str(globals -> adapt.ac_state));
+ prev_state = globals -> adapt.ac_state;
+ }
+}
+
+char * thermal_state_str(thermal_state_t ts)
+{
+ switch(ts)
+ {
+ case T_CRIT:
+ return "critical temperature, will switch to S4";
+
+ case T_HOT:
+ return "high temperature, will shutdown immediately";
+
+ case T_PASS:
+ return "passive cooling";
+
+ case T_ACT:
+ return "active cooling";
+
+ case T_OK:
+ return "ok";
+
+ case T_ERR:
+ return "error";
+ }
+
+ return "?";
+}
+
+void emit_zone(global_t *globals, char *header_shown)
+{
+ int loop;
+ static int *prevs = NULL;
+ static int *prevs_ts = NULL;
+
+ if (!prevs)
+ {
+ int bytes = sizeof(int) * globals -> thermal_count;
+ prevs = malloc(bytes);
+ prevs_ts = malloc(bytes);
+ memset(prevs, 0x00, bytes);
+ memset(prevs_ts, 0x00, bytes);
+ }
+
+ for(loop=0; loop<globals -> thermal_count; loop++)
+ {
+ int rc = read_acpi_zone(loop, globals);
+
+ if (rc == ITEM_EXCEED)
+ break;
+ if (rc == ALLOC_ERR)
+ error_exit("reac_acpi_zone(%d) failed\n", loop);
+
+ if (prevs[loop] != thermals[loop].temperature ||
+ prevs_ts[loop] != thermals[loop].therm_state)
+ {
+ header(header_shown);
+ printf("temperature %s: %d (%s)\n", thermals[loop].name, thermals[loop].temperature, thermal_state_str(thermals[loop].therm_state));
+ prevs[loop] = thermals[loop].temperature;
+ prevs_ts[loop] = thermals[loop].therm_state;
+ }
+ }
+}
+
+char * fan_state_str(fan_state_t fs)
+{
+ switch(fs)
+ {
+ case F_ON:
+ return "on";
+
+ case F_OFF:
+ return "off";
+
+ case F_ERR:
+ return "error state";
+ }
+
+ return "?";
+}
+
+void emit_fan(global_t *globals, char *header_shown)
+{
+ int loop;
+ static int *prevs = NULL;
+
+ if (!prevs)
+ {
+ int bytes = sizeof(int) * globals -> fan_count;
+ prevs = malloc(bytes);
+ memset(prevs, 0x00, bytes);
+ }
+
+ for(loop=0; loop<globals -> fan_count; loop++)
+ {
+ int rc = read_acpi_fan(loop);
+
+ if (rc == ITEM_EXCEED)
+ break;
+ if (rc == ALLOC_ERR)
+ error_exit("reac_acpi_fan(%d) failed\n", loop);
+
+ if (prevs[loop] != fans[loop].fan_state)
+ {
+ header(header_shown);
+ printf("fan %s: %s\n", fans[loop].name, fan_state_str(fans[loop].fan_state));
+ prevs[loop] = fans[loop].fan_state;
+ }
+ }
+}
diff --git a/emit.h b/emit.h
new file mode 100644
index 0000000..91472e3
--- /dev/null
+++ b/emit.h
@@ -0,0 +1,4 @@
+void emit_battery(global_t *globals, char *header_shown);
+void emit_acstate(global_t *globals, char *header_shown);
+void emit_zone(global_t *globals, char *header_shown);
+void emit_fan(global_t *globals, char *header_shown);
diff --git a/error.c b/error.c
new file mode 100644
index 0000000..50c0306
--- /dev/null
+++ b/error.c
@@ -0,0 +1,20 @@
+#include <errno.h>
+#include <stdarg.h>
+#include <stdio.h>
+#include <stdlib.h>
+#include <sys/types.h>
+#include <signal.h>
+
+void error_exit(char *format, ...)
+{
+ char buffer[4096];
+ va_list ap;
+
+ va_start(ap, format);
+ vsnprintf(buffer, sizeof(buffer), format, ap);
+ va_end(ap);
+
+ fprintf(stderr, "%s: errno=%d (if applicable)\n", buffer, errno);
+
+ exit(EXIT_FAILURE);
+}
diff --git a/error.h b/error.h
new file mode 100644
index 0000000..e673a05
--- /dev/null
+++ b/error.h
@@ -0,0 +1 @@
+void error_exit(char *format, ...);
diff --git a/license.txt b/license.txt
new file mode 100644
index 0000000..960fe74
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,280 @@
+ GNU GENERAL PUBLIC LICENSE
+ Version 2, June 1991
+
+ Copyright (C) 1989, 1991 Free Software Foundation, Inc.
+ 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ Everyone is permitted to copy and distribute verbatim copies
+ of this license document, but changing it is not allowed.
+
+ Preamble
+
+ The licenses for most software are designed to take away your
+freedom to share and change it. By contrast, the GNU General Public
+License is intended to guarantee your freedom to share and change free
+software--to make sure the software is free for all its users. This
+General Public License applies to most of the Free Software
+Foundation's software and to any other program whose authors commit to
+using it. (Some other Free Software Foundation software is covered by
+the GNU Library General Public License instead.) You can apply it to
+your programs, too.
+
+ When we speak of free software, we are referring to freedom, not
+price. Our General Public Licenses are designed to make sure that you
+have the freedom to distribute copies of free software (and charge for
+this service if you wish), that you receive source code or can get it
+if you want it, that you can change the software or use pieces of it
+in new free programs; and that you know you can do these things.
+
+ To protect your rights, we need to make restrictions that forbid
+anyone to deny you these rights or to ask you to surrender the rights.
+These restrictions translate to certain responsibilities for you if you
+distribute copies of the software, or if you modify it.
+
+ For example, if you distribute copies of such a program, whether
+gratis or for a fee, you must give the recipients all the rights that
+you have. You must make sure that they, too, receive or can get the
+source code. And you must show them these terms so they know their
+rights.
+
+ We protect your rights with two steps: (1) copyright the software, and
+(2) offer you this license which gives you legal permission to copy,
+distribute and/or modify the software.
+
+ Also, for each author's protection and ours, we want to make certain
+that everyone understands that there is no warranty for this free
+software. If the software is modified by someone else and passed on, we
+want its recipients to know that what they have is not the original, so
+that any problems introduced by others will not reflect on the original
+authors' reputations.
+
+ Finally, any free program is threatened constantly by software
+patents. We wish to avoid the danger that redistributors of a free
+program will individually obtain patent licenses, in effect making the
+program proprietary. To prevent this, we have made it clear that any
+patent must be licensed for everyone's free use or not licensed at all.
+
+ The precise terms and conditions for copying, distribution and
+modification follow.
+
+ GNU GENERAL PUBLIC LICENSE
+ TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+
+ 0. This License applies to any program or other work which contains
+a notice placed by the copyright holder saying it may be distributed
+under the terms of this General Public License. The "Program", below,
+refers to any such program or work, and a "work based on the Program"
+means either the Program or any derivative work under copyright law:
+that is to say, a work containing the Program or a portion of it,
+either verbatim or with modifications and/or translated into another
+language. (Hereinafter, translation is included without limitation in
+the term "modification".) Each licensee is addressed as "you".
+
+Activities other than copying, distribution and modification are not
+covered by this License; they are outside its scope. The act of
+running the Program is not restricted, and the output from the Program
+is covered only if its contents constitute a work based on the
+Program (independent of having been made by running the Program).
+Whether that is true depends on what the Program does.
+
+ 1. You may copy and distribute verbatim copies of the Program's
+source code as you receive it, in any medium, provided that you
+conspicuously and appropriately publish on each copy an appropriate
+copyright notice and disclaimer of warranty; keep intact all the
+notices that refer to this License and to the absence of any warranty;
+and give any other recipients of the Program a copy of this License
+along with the Program.
+
+You may charge a fee for the physical act of transferring a copy, and
+you may at your option offer warranty protection in exchange for a fee.
+
+ 2. You may modify your copy or copies of the Program or any portion
+of it, thus forming a work based on the Program, and copy and
+distribute such modifications or work under the terms of Section 1
+above, provided that you also meet all of these conditions:
+
+ a) You must cause the modified files to carry prominent notices
+ stating that you changed the files and the date of any change.
+
+ b) You must cause any work that you distribute or publish, that in
+ whole or in part contains or is derived from the Program or any
+ part thereof, to be licensed as a whole at no charge to all third
+ parties under the terms of this License.
+
+ c) If the modified program normally reads commands interactively
+ when run, you must cause it, when started running for such
+ interactive use in the most ordinary way, to print or display an
+ announcement including an appropriate copyright notice and a
+ notice that there is no warranty (or else, saying that you provide
+ a warranty) and that users may redistribute the program under
+ these conditions, and telling the user how to view a copy of this
+ License. (Exception: if the Program itself is interactive but
+ does not normally print such an announcement, your work based on
+ the Program is not required to print an announcement.)
+
+These requirements apply to the modified work as a whole. If
+identifiable sections of that work are not derived from the Program,
+and can be reasonably considered independent and separate works in
+themselves, then this License, and its terms, do not apply to those
+sections when you distribute them as separate works. But when you
+distribute the same sections as part of a whole which is a work based
+on the Program, the distribution of the whole must be on the terms of
+this License, whose permissions for other licensees extend to the
+entire whole, and thus to each and every part regardless of who wrote it.
+
+Thus, it is not the intent of this section to claim rights or contest
+your rights to work written entirely by you; rather, the intent is to
+exercise the right to control the distribution of derivative or
+collective works based on the Program.
+
+In addition, mere aggregation of another work not based on the Program
+with the Program (or with a work based on the Program) on a volume of
+a storage or distribution medium does not bring the other work under
+the scope of this License.
+
+ 3. You may copy and distribute the Program (or a work based on it,
+under Section 2) in object code or executable form under the terms of
+Sections 1 and 2 above provided that you also do one of the following:
+
+ a) Accompany it with the complete corresponding machine-readable
+ source code, which must be distributed under the terms of Sections
+ 1 and 2 above on a medium customarily used for software interchange; or,
+
+ b) Accompany it with a written offer, valid for at least three
+ years, to give any third party, for a charge no more than your
+ cost of physically performing source distribution, a complete
+ machine-readable copy of the corresponding source code, to be
+ distributed under the terms of Sections 1 and 2 above on a medium
+ customarily used for software interchange; or,
+
+ c) Accompany it with the information you received as to the offer
+ to distribute corresponding source code. (This alternative is
+ allowed only for noncommercial distribution and only if you
+ received the program in object code or executable form with such
+ an offer, in accord with Subsection b above.)
+
+The source code for a work means the preferred form of the work for
+making modifications to it. For an executable work, complete source
+code means all the source code for all modules it contains, plus any
+associated interface definition files, plus the scripts used to
+control compilation and installation of the executable. However, as a
+special exception, the source code distributed need not include
+anything that is normally distributed (in either source or binary
+form) with the major components (compiler, kernel, and so on) of the
+operating system on which the executable runs, unless that component
+itself accompanies the executable.
+
+If distribution of executable or object code is made by offering
+access to copy from a designated place, then offering equivalent
+access to copy the source code from the same place counts as
+distribution of the source code, even though third parties are not
+compelled to copy the source along with the object code.
+
+ 4. You may not copy, modify, sublicense, or distribute the Program
+except as expressly provided under this License. Any attempt
+otherwise to copy, modify, sublicense or distribute the Program is
+void, and will automatically terminate your rights under this License.
+However, parties who have received copies, or rights, from you under
+this License will not have their licenses terminated so long as such
+parties remain in full compliance.
+
+ 5. You are not required to accept this License, since you have not
+signed it. However, nothing else grants you permission to modify or
+distribute the Program or its derivative works. These actions are
+prohibited by law if you do not accept this License. Therefore, by
+modifying or distributing the Program (or any work based on the
+Program), you indicate your acceptance of this License to do so, and
+all its terms and conditions for copying, distributing or modifying
+the Program or works based on it.
+
+ 6. Each time you redistribute the Program (or any work based on the
+Program), the recipient automatically receives a license from the
+original licensor to copy, distribute or modify the Program subject to
+these terms and conditions. You may not impose any further
+restrictions on the recipients' exercise of the rights granted herein.
+You are not responsible for enforcing compliance by third parties to
+this License.
+
+ 7. If, as a consequence of a court judgment or allegation of patent
+infringement or for any other reason (not limited to patent issues),
+conditions are imposed on you (whether by court order, agreement or
+otherwise) that contradict the conditions of this License, they do not
+excuse you from the conditions of this License. If you cannot
+distribute so as to satisfy simultaneously your obligations under this
+License and any other pertinent obligations, then as a consequence you
+may not distribute the Program at all. For example, if a patent
+license would not permit royalty-free redistribution of the Program by
+all those who receive copies directly or indirectly through you, then
+the only way you could satisfy both it and this License would be to
+refrain entirely from distribution of the Program.
+
+If any portion of this section is held invalid or unenforceable under
+any particular circumstance, the balance of the section is intended to
+apply and the section as a whole is intended to apply in other
+circumstances.
+
+It is not the purpose of this section to induce you to infringe any
+patents or other property right claims or to contest validity of any
+such claims; this section has the sole purpose of protecting the
+integrity of the free software distribution system, which is
+implemented by public license practices. Many people have made
+generous contributions to the wide range of software distributed
+through that system in reliance on consistent application of that
+system; it is up to the author/donor to decide if he or she is willing
+to distribute software through any other system and a licensee cannot
+impose that choice.
+
+This section is intended to make thoroughly clear what is believed to
+be a consequence of the rest of this License.
+
+ 8. If the distribution and/or use of the Program is restricted in
+certain countries either by patents or by copyrighted interfaces, the
+original copyright holder who places the Program under this License
+may add an explicit geographical distribution limitation excluding
+those countries, so that distribution is permitted only in or among
+countries not thus excluded. In such case, this License incorporates
+the limitation as if written in the body of this License.
+
+ 9. The Free Software Foundation may publish revised and/or new versions
+of the General Public License from time to time. Such new versions will
+be similar in spirit to the present version, but may differ in detail to
+address new problems or concerns.
+
+Each version is given a distinguishing version number. If the Program
+specifies a version number of this License which applies to it and "any
+later version", you have the option of following the terms and conditions
+either of that version or of any later version published by the Free
+Software Foundation. If the Program does not specify a version number of
+this License, you may choose any version ever published by the Free Software
+Foundation.
+
+ 10. If you wish to incorporate parts of the Program into other free
+programs whose distribution conditions are different, write to the author
+to ask for permission. For software which is copyrighted by the Free
+Software Foundation, write to the Free Software Foundation; we sometimes
+make exceptions for this. Our decision will be guided by the two goals
+of preserving the free status of all derivatives of our free software and
+of promoting the sharing and reuse of software generally.
+
+ NO WARRANTY
+
+ 11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY
+FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN
+OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES
+PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED
+OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS
+TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE
+PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING,
+REPAIR OR CORRECTION.
+
+ 12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING
+WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR
+REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES,
+INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING
+OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED
+TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY
+YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER
+PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGES.
+
+ END OF TERMS AND CONDITIONS
diff --git a/readme.txt b/readme.txt
new file mode 100644
index 0000000..f766622
--- /dev/null
+++ b/readme.txt
@@ -0,0 +1,27 @@
+Show battery/fan/temperature info in a tail-like style.
+
+
+installation:
+------------
+type:
+make install
+and that's it!
+This program requires libacpi by Nico Golde:
+http://ngolde.de/libacpi.html
+
+
+MultiTail colorscheme:
+---------------------
+colorscheme:acpitail:Show temperature/battery/etc info
+cs_re:magenta::
+cs_re:magenta:-
+cs_re:blue|blue,,bold:... ... [0-9]* ..:..:.. 2...
+cs_re_val_less:red,,bold:5:^.* remaining capacity: .* .([0-9]*) minutes
+cs_re_val_less:yellow:10:^.*remaining capacity: .* .([0-9]*) minutes
+cs_re:red:error.*
+cs_re_val_bigger:yellow:55:temperature.*: ([0-9]*)
+cs_re_val_bigger:red,,bold:65:temperature.*: ([0-9]*)
+
+
+For everything more or less related to 'acpitail', please feel free
+to contact me on: folkert@vanheusden.com
diff --git a/sched.c b/sched.c
new file mode 100644
index 0000000..be48e3c
--- /dev/null
+++ b/sched.c
@@ -0,0 +1,25 @@
+#include <time.h>
+#include <unistd.h>
+
+#include "sched.h"
+
+#define min(x, y) ((x) < (y)?(x) : (y))
+
+void sleep_untill_next_event(sched_t *psched, int n_sched)
+{
+ time_t now = time(NULL);
+ int loop;
+ int sleep_n = now + 3600;
+
+ for(loop=0; loop<n_sched; loop++)
+ {
+ time_t cur_next_schedule = psched[loop].last_run + psched[loop].interval;
+
+ sleep_n = min(sleep_n, cur_next_schedule - now);
+ if (sleep_n < 0)
+ sleep_n = 0;
+ }
+
+ if (sleep_n > 0)
+ sleep(sleep_n);
+}
diff --git a/sched.h b/sched.h
new file mode 100644
index 0000000..ceae3ed
--- /dev/null
+++ b/sched.h
@@ -0,0 +1,21 @@
+#define SCHED_BATT 0 /* batteries */
+#define SCHED_ACSTATE 1 /* ac state */
+#define SCHED_ZONE 2 /* zones */
+#define SCHED_FAN 3 /* fans */
+
+#define N_SCHED 4
+
+/* Default Interval */
+#define DI_ACSTATE 300
+#define DI_BATT 15
+#define DI_ZONE 5
+#define DI_FAN 5
+
+typedef struct
+{
+ int what;
+ time_t last_run;
+ int interval;
+} sched_t;
+
+void sleep_untill_next_event(sched_t *psched, int n_sched);