summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorTobias Klauser <tklauser@distanz.ch>2007-03-03 17:25:42 +0100
committerTobias Klauser <tklauser@xenon.tklauser.home>2007-03-03 17:25:42 +0100
commit5858819e4e3bc738463e8f7cc7d808a388ebc6c1 (patch)
tree45a03442ed7349b5dc0b3707f4bde67631929469 /Makefile
Initial import of debian package for inotail0.2-1
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13b67c3
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,44 @@
+# Makefile for inotail
+#
+# Copyright (C) 2006, Tobias Klauser <tklauser@distanz.ch>
+#
+# Licensed under the terms of the GNU General Public License; version 2 or later.
+
+VERSION = 0.2
+
+# Paths
+prefix = /usr
+DESTDIR =
+
+CC := gcc
+CFLAGS := -Wall -pipe -D_USE_SOURCE -DVERSION="\"$(VERSION)\""
+WARN := -Wstrict-prototypes -Wsign-compare -Wshadow \
+ -Wchar-subscripts -Wmissing-declarations -Wnested-externs \
+ -Wpointer-arith -Wcast-align -Wmissing-prototypes
+CFLAGS += $(WARN)
+
+# Compile with 'make DEBUG=true' to enable debugging
+DEBUG = false
+ifeq ($(strip $(DEBUG)),true)
+ CFLAGS += -g -DDEBUG
+endif
+
+all: Makefile inotail
+inotail: inotail.o
+
+%.o: %.c %.h
+ $(CC) $(CFLAGS) -c $< -o $@
+
+install: inotail
+ install -m 775 -D inotail $(DESTDIR)$(prefix)/bin/inotail
+ install -m 644 -D inotail.1 $(DESTDIR)$(prefix)/share/man/man1/inotail.1
+
+cscope:
+ cscope -b
+
+release:
+ git-archive --format=tar --prefix=inotail-0.2/ HEAD | gzip -9v > ../inotail-$(VERSION).tar.gz
+ git-archive --format=tar --prefix=inotail-0.2/ HEAD | bzip2 -9v > ../inotail-$(VERSION).tar.bz2
+
+clean:
+ rm -f inotail *.o cscope.*