summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTobias Klauser <tklauser@distanz.ch>2007-03-03 17:25:42 +0100
committerTobias Klauser <tklauser@xenon.tklauser.home>2007-03-03 17:25:42 +0100
commit5858819e4e3bc738463e8f7cc7d808a388ebc6c1 (patch)
tree45a03442ed7349b5dc0b3707f4bde67631929469 /debian
Initial import of debian package for inotail0.2-1
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog11
-rw-r--r--debian/compat1
-rw-r--r--debian/control19
-rw-r--r--debian/copyright47
-rw-r--r--debian/docs1
-rwxr-xr-xdebian/rules48
6 files changed, 127 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..6f4d25b
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,11 @@
+inotail (0.2-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Tobias Klauser <tklauser@access.unizh.ch> Mon, 4 Dec 2006 20:32:53 +0100
+
+inotail (0.1-1) unstable; urgency=low
+
+ * Initial release. (Closes: #388512)
+
+ -- Tobias Klauser <tklauser@access.unizh.ch> Tue, 22 Aug 2006 23:22:55 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..6362a90
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,19 @@
+Source: inotail
+Section: utils
+Priority: optional
+Maintainer: Tobias Klauser <tklauser@access.unizh.ch>
+Build-Depends: debhelper (>= 4)
+Standards-Version: 3.7.2
+
+Package: inotail
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: tail replacement using inotify
+ inotail is a replacement for the 'tail' program found in the base installation
+ of every Linux/UNIX system. It makes use of the inotify infrastructure in
+ recent versions of the Linux kernel to speed up tailing files in the follow
+ mode (the '-f' option). Standard tail polls the file every second by default
+ while inotail listens to special events sent by the kernel through the inotify
+ API to determine whether a file needs to be reread.
+ .
+ Homepage: <http://distanz.ch/inotail>
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..d2745f5
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,47 @@
+This package was debianized by Tobias Klauser <tklauser@access.unizh.ch> on
+Tue, 22 Aug 2006 23:22:55 +0200.
+
+It was downloaded from <http://distanz.ch/inotail>.
+
+Upstream Author: Tobias Klauser <tklauser@distanz.ch>
+
+License (inotify.h and inotify-syscalls.h):
+
+ Copyright (C) 2005 John McCutchan
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 of the License.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in /usr/share/common-licenses/GPL file.
+
+License (everything else):
+
+ Copyright (C) 2005-2006 Tobias Klauser <tklauser@distanz.ch>
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in /usr/share/common-licenses/GPL file.
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e845566
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8618b96
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,48 @@
+#!/usr/bin/make -f
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+
+ $(MAKE)
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ $(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/inotail
+
+binary-indep: build install
+# We have nothing to do by default.
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_install
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install