summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile29
1 files changed, 14 insertions, 15 deletions
diff --git a/Makefile b/Makefile
index 13b67c3..cfeb89a 100644
--- a/Makefile
+++ b/Makefile
@@ -1,21 +1,20 @@
# Makefile for inotail
#
-# Copyright (C) 2006, Tobias Klauser <tklauser@distanz.ch>
+# Copyright (C) 2006-2007 Tobias Klauser <tklauser@distanz.ch>
#
# Licensed under the terms of the GNU General Public License; version 2 or later.
-VERSION = 0.2
+VERSION = 0.3
# Paths
-prefix = /usr
-DESTDIR =
+prefix = /usr/local
+BINDIR = $(prefix)/bin
+MANDIR = $(prefix)/share/man/man1
-CC := gcc
-CFLAGS := -Wall -pipe -D_USE_SOURCE -DVERSION="\"$(VERSION)\""
-WARN := -Wstrict-prototypes -Wsign-compare -Wshadow \
- -Wchar-subscripts -Wmissing-declarations -Wnested-externs \
- -Wpointer-arith -Wcast-align -Wmissing-prototypes
-CFLAGS += $(WARN)
+CC := gcc
+CFLAGS := $(CFLAGS) -W -Wall -pipe -D_USE_SOURCE -DVERSION="\"$(VERSION)\"" \
+ -Wstrict-prototypes -Wsign-compare -Wshadow -Wchar-subscripts \
+ -Wmissing-declarations -Wpointer-arith -Wcast-align -Wmissing-prototypes
# Compile with 'make DEBUG=true' to enable debugging
DEBUG = false
@@ -23,22 +22,22 @@ ifeq ($(strip $(DEBUG)),true)
CFLAGS += -g -DDEBUG
endif
-all: Makefile inotail
+all: inotail
inotail: inotail.o
%.o: %.c %.h
$(CC) $(CFLAGS) -c $< -o $@
install: inotail
- install -m 775 -D inotail $(DESTDIR)$(prefix)/bin/inotail
- install -m 644 -D inotail.1 $(DESTDIR)$(prefix)/share/man/man1/inotail.1
+ install -m 775 -D inotail $(BINDIR)/inotail
+ install -m 644 -D inotail.1 $(MANDIR)/inotail.1
cscope:
cscope -b
release:
- git-archive --format=tar --prefix=inotail-0.2/ HEAD | gzip -9v > ../inotail-$(VERSION).tar.gz
- git-archive --format=tar --prefix=inotail-0.2/ HEAD | bzip2 -9v > ../inotail-$(VERSION).tar.bz2
+ git-archive --format=tar --prefix=inotail-$(VERSION)/ HEAD | gzip -9v > ../inotail-$(VERSION).tar.gz
+ git-archive --format=tar --prefix=inotail-$(VERSION)/ HEAD | bzip2 -9v > ../inotail-$(VERSION).tar.bz2
clean:
rm -f inotail *.o cscope.*