summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index cfeb89a..bcb8cd4 100644
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,7 @@
#
# Licensed under the terms of the GNU General Public License; version 2 or later.
-VERSION = 0.3
+VERSION = 0.4
# Paths
prefix = /usr/local
@@ -12,7 +12,7 @@ BINDIR = $(prefix)/bin
MANDIR = $(prefix)/share/man/man1
CC := gcc
-CFLAGS := $(CFLAGS) -W -Wall -pipe -D_USE_SOURCE -DVERSION="\"$(VERSION)\"" \
+CFLAGS := $(CFLAGS) -pipe -D_USE_SOURCE -DVERSION="\"$(VERSION)\"" -W -Wall \
-Wstrict-prototypes -Wsign-compare -Wshadow -Wchar-subscripts \
-Wmissing-declarations -Wpointer-arith -Wcast-align -Wmissing-prototypes
@@ -31,6 +31,10 @@ inotail: inotail.o
install: inotail
install -m 775 -D inotail $(BINDIR)/inotail
install -m 644 -D inotail.1 $(MANDIR)/inotail.1
+ gzip -9 $(MANDIR)/inotail.1
+
+uninstall:
+ rm $(BINDIR)/inotail $(MANDIR)/inotail.1*
cscope:
cscope -b