summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTobias Klauser <tklauser@distanz.ch>2008-10-08 19:40:31 +0200
committerTobias Klauser <tklauser@xenon.tklauser.home>2008-10-08 19:40:31 +0200
commit474c496e8851e4f940abab0dc7aeea7fe7dabcf9 (patch)
tree95d1099f6b97b11450ee0c79419d907832af6355 /debian
parent2a441ecbea378da1a2cdea969c48bb7d9e547135 (diff)
Adapt package to new source layout.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/patches/01-abs-llabs.dpatch6
-rwxr-xr-xdebian/rules12
3 files changed, 17 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 55a015c..f92f845 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+lfhex (0.42-1) UNRELEASED; urgency=low
+
+ * New upstream release.
+ * Acknowledge NMU.
+
+ -- Tobias Klauser <tklauser@access.unizh.ch> Wed, 08 Oct 2008 19:27:26 +0200
+
lfhex (0.4-3) unstable; urgency=low
* Actually apply the patch to fix FTBFS. Really Closes: #495467 this time.
diff --git a/debian/patches/01-abs-llabs.dpatch b/debian/patches/01-abs-llabs.dpatch
index 7515266..74ffcbc 100755
--- a/debian/patches/01-abs-llabs.dpatch
+++ b/debian/patches/01-abs-llabs.dpatch
@@ -4,9 +4,9 @@
## DP: Fixes FTBFS due to abs() not being in the global anymore since g++ 4.3
## (#495467)
-diff -up lfhex-0.4.orig/reader.cpp lfhex-0.4/reader.cpp
---- lfhex-0.4.orig/reader.cpp 2006-11-05 04:26:04.000000000 +0000
-+++ lfhex-0.4/reader.cpp 2008-08-16 22:43:44.000000000 +0100
+diff -up lfhex-0.42.orig/src/reader.cpp lfhex-0.42/src/reader.cpp
+--- lfhex-0.42.orig/src/reader.cpp 2008-10-08 19:25:57.000000000 +0200
++++ lfhex-0.42/src/reader.cpp 2008-10-08 19:26:16.000000000 +0200
@@ -238,7 +238,7 @@ bool Reader::loadPage(off_t pageIdx)
// free the page which is the furthest away from the page we are loading
diff --git a/debian/rules b/debian/rules
index 3e148bf..0a474b9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,11 +2,13 @@
include /usr/share/dpatch/dpatch.make
+SRCDIR=src
+
configure: configure-stamp
configure-stamp: patch-stamp
dh_testdir
- qmake-qt4 lfhex.pro
+ cd $(SRCDIR) && qmake-qt4 lfhex.pro
touch configure-stamp
@@ -15,7 +17,7 @@ build: build-stamp
build-stamp: configure-stamp
dh_testdir
- $(MAKE)
+ cd $(SRCDIR) && $(MAKE)
touch $@
@@ -24,8 +26,8 @@ clean: unpatch
dh_testroot
rm -f build-stamp configure-stamp
- [ ! -f Makefile ] || $(MAKE) clean
- rm -f Makefile lfhex
+ cd $(SRCDIR) && ([ ! -f Makefile ] || $(MAKE) clean)
+ rm -f $(SRCDIR)/Makefile $(SRCDIR)/lfhex
dh_clean
@@ -37,7 +39,7 @@ install: build
# Do a manual install, qmake does not correctly generate an install
# target
- install -D -m755 -p lfhex $(CURDIR)/debian/lfhex/usr/bin/lfhex
+ cd $(SRCDIR) && install -D -m755 -p lfhex $(CURDIR)/debian/lfhex/usr/bin/lfhex
# Build architecture-independent files here.
binary-indep: