summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules49
3 files changed, 6 insertions, 46 deletions
diff --git a/debian/changelog b/debian/changelog
index 595962b..21f54ec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,6 @@
inotail (0.5-2) unstable; urgency=low
+ * Minimize rules file by using the dh command sequencer.
* Include ${misc:Depends} into Depends in control.
* Replace obsolete dh_clean -k with dh_prep in rules.
* Update debhelper compatibility level from 5 to 7.
diff --git a/debian/control b/debian/control
index a3eed01..a95e48c 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: inotail
Section: utils
Priority: optional
Maintainer: Tobias Klauser <tklauser@distanz.ch>
-Build-Depends: debhelper (>= 7)
+Build-Depends: debhelper (>= 7.0.50)
Standards-Version: 3.8.3
Homepage: http://distanz.ch/inotail
Vcs-Git: http://git.distanz.ch/scm/debian/pkg-inotail.git
diff --git a/debian/rules b/debian/rules
index 786c709..1fd8c5b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,48 +1,7 @@
#!/usr/bin/make -f
-build: build-stamp
-build-stamp:
- dh_testdir
+%:
+ dh ${@}
- $(MAKE)
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- $(MAKE) clean
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
-
- $(MAKE) install prefix=$(CURDIR)/debian/inotail/usr
-
-binary-indep: build install
-# We have nothing to do by default.
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs changelog
- dh_installdocs
- dh_install
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_install:
+ dh_auto_install -- prefix=$(CURDIR)/debian/inotail/usr